HDU 5937 Game of Taking Stones 【威佐夫博弈+大数+高精度】

Problem Description

Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?

Input

Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than $10^{100}$.

Output

For each test data,output answer on one line.1 means you are the winner,otherwise output 0.

Sample Input

2 1 8 4 4 7

Sample Output

0 1 0

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

题意:

全裸的威佐夫博弈,但是输入的两个数长度长达100位

思路:

对于该题,数据范围是10的100次方,还有小数乘法 —-> 黄金分割率需要精确到小数点后100位 —-> 通过二分求解。

威佐夫博弈:

a为a、b中较小的数,先手是否会赢 —–> $ \frac{\sqrt5+1}{2} \times (b - a) $ == a ? lose : win

AC代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
import java.math.BigInteger;
import java.math.BigDecimal;
import java.util.*;

public class Main {
public static void main(String[] args)
{
Scanner scanner = new Scanner(System.in);
BigDecimal TWO = BigDecimal.valueOf(2);
BigDecimal FIVE = BigDecimal.valueOf(5);

BigDecimal EPS = new BigDecimal("-0.000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");

BigDecimal L = new BigDecimal("2.2360679774997");
BigDecimal R = new BigDecimal("2.2360679774998");
BigDecimal mid = null;

while(L.subtract(R).compareTo(EPS) < 0)
{
mid = L.add(R).divide(TWO);
if(mid.multiply(mid).subtract(FIVE).abs().compareTo(EPS.abs()) < 0)
break;
if(mid.multiply(mid).subtract(FIVE).compareTo(EPS) < 0)
L = mid;
else
R = mid;
}

BigDecimal GOLD = mid.add(BigDecimal.ONE).divide(TWO);
//System.out.println(GOLD);

while(scanner.hasNext())
{
BigDecimal a = scanner.nextBigDecimal();
BigDecimal b = scanner.nextBigDecimal();
if(a.compareTo(b) > 0) //保证a是小的
{
BigDecimal t = a;
a = b;
b = t;
}
BigDecimal c = b.subtract(a).multiply(GOLD);

BigInteger aa = a.toBigInteger();
BigInteger cc = c.toBigInteger();
if(aa.equals(cc))
System.out.println("0");
else
System.out.println("1");
}
}
}
Donate comment here
0%